0

I'm trying to make use of the autocomplete facilities of AUCTeX using M-TAB (actually, through the equivalent binding C-M-i), but apparently, when using flyspell-mode alongside with LaTeX-mode the flyspell command flyspell-auto-correct-word overrides TeX-complete-symbol.

So, if I try the AUCTeX manual's example \renewc, with dictionary set to en_US, when pressing C-M-i, I get the following sequence:

\renew -> \renews -> \renew c -> \Rene -> \Corene -> \newcomer -> \crewmen and so on

With plain ispell it works as expected, but I'd like to keep flyspell if possible.

Any suggestions to get around this?

1

I quote here the help of the customization option flyspell-use-meta-tab as answer:

flyspell-use-meta-tab is a variable defined in ‘flyspell.el’.
Its value is nil
Original value was t

Documentation:
Non-nil means that flyspell uses M-TAB to correct word.

You can customize this variable.

You can set that variable to nil by M-x customize-option RET flyspell-use-meta-tab.

  • I had seen this, but didn't want to loose the functionality. As it turns out, with your suggestion, the binding is then left to ispell-complete-word, which works well, and doesn't mess with TeX-complete-symbol. So, thanks! – gusbrs May 30 '18 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.