Using an icicles menu with emacs 26.1, I'm now having the menu sorted.

The menu used to be unsorted (items appeared in the order they were given). In the previous version of emacs they were unsorted.

How can I call the menu so it keeps the items unsorted?

See: https://emacs.stackexchange.com/a/38752/2418

  • Possible duplicate of How to stop "completing-read" / "ivy-completing-read" from sorting?
    – ideasman42
    Commented Jun 2, 2018 at 7:27
  • 2
    It's not at all a duplicate of that question. One was explicitly about Icicles, the other explicitly about Ivy. There is nothing in common between how/when/why sorting is done in the two cases. But the question should be closed anyway, as you clearly really wanted to ask about Ivy, not Icicles.
    – Drew
    Commented Jun 2, 2018 at 14:11

1 Answer 1


I think you'll need to be more precise in your description. I can't repro the problem, except that completion-candidate sorting is on by default.

That is, the default value of option icicle-sort-comparer is icicle-case-string-less-p: sort alphabetically, respecting completion-ignore-case.

As always, you can change the sort order on the fly, including turning sorting off, using C-,. And you can customize option icicle-sort-comparer to turn sorting off by default.

And (more relevant here, perhaps) you can bind icicle-sort-comparer in any command you write, to get the kind of default sorting (including not sorting) you want. Just bind it to nil to turn sorting off by default for that command. (Users of the command can still use C-, to change the sort order on the fly.)

Try to provide a step-by-step recipe to repro the problem you see, preferably starting from emacs -Q (or at least show the values of Icicles options you might have customized).

  • Thanks for the answer, unfortunately I'm not all that experienced and it turns out icy-mode wasn't even enabled. instead ivy mode was overwriting my completing-read. I've since solved the issue and closed this as a duplicate.
    – ideasman42
    Commented Jun 2, 2018 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.