3

Can I disable this kind of a popup?enter image description here

I couldn't find anything besides (setq x-gtk-use-system-tooltips nil), but it didin't help me unfortunately.

  • Note that GUI dialogs only ever appear in response to mouse events. If you don't do things with the mouse, you won't see them at all. – phils Jun 1 '18 at 4:43
  • Unfortunately, it's not true. I definitely don't do things with a mouse when this dialog appears. – valignatev Jun 1 '18 at 5:06
  • That's unusual behaviour, then. Does your example happen when you use C-x C-f to visit such a symlink? The prompt would normally be in the minibuffer in that scenario. Does the same thing happen when you run emacs -Q ? – phils Jun 1 '18 at 5:47
  • 1
    Ah, C-h v use-dialog-box says "On some platforms, file selection dialogs are also enabled if this is non-nil." so I guess that's what's happening? Sorry for my confusion -- I was entirely oblivious to this working differently on different platforms. Which OS is this? – phils Jun 1 '18 at 15:46
  • 1
    I've mostly used Debian and derivative GNU/Linux systems, and have never encountered this, to my recollection. I'm not really familiar with Arch, but it seems surprising to me that it would be different. I have no knowledge of how/why this platform-specific behaviour exists, though. Thanks for the follow-ups -- I've learned something new here. – phils Jun 1 '18 at 15:54
3

To disable dialog windows set use-dialog-box to nil

(setq use-dialog-box nil)
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.