Even though gnutls-devel.x86_64 is installed on my RedHat 6.6 system. How do I guide the configure script to the required libraries?

[update 2018-06-03 after hint from Ian] In fact configure found the libraries but in config.log it says that the library is too old.

Now I'm trying to compile GnuTLS 3.5.18. but it's configure script says that it requires Libnettle 3.1. (whatever this is).

So I'm trying to compile a package called nettle 3.4. which is supposed to include libnettle libs. This configure script runs through but when I'm doing make it says: cd: tools: No such file or directory!

Basically I'm stuck at this stage, what can I do to investigate this mess further?


Try to install pkg-config.

I met same trouble in Ubuntu 1804 on Windows Subsystem for Linux. I read configure script, and found the script uses pkg-config to check version of gnutls.

| improve this answer | |
  • 1
    Can you provide a link to pkg-config? – Drew Jun 15 '18 at 16:26
  • after run 'apt-get install -y pkg-config', the issue is resolved. Thanks – Jackliusr Oct 23 '18 at 10:25

To avoid the mess you found yourself in, I compiled emacs 26.1 on CentOS 6.5 by doing: configure --with-gnutls=no

| improve this answer | |
  • This is also suggested by the configure script! But is no solution for me I need gnutls for the package support and https pages in eww. – Dieter.Wilhelm Jun 8 '18 at 17:50
  • What does gnutils provide? I might just fall back to 25.x instead if that works. So does anyone have a path forward on this to get emacs to cleanly compile with the default configure? gnutils should able to be built and upgraded without too much problem. – Carl Zmola Aug 30 '19 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.