1

I get the above message using the latest magit from melpa. This occurs with

GNU Emacs 25.1.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9) of 2016-12-20

on Ubuntu 16.04.

Any ideas?

5
  • 2
    Records are a new feature in Emacs 26.1. Did you recently try out a newer Emacs version and while doing so update Magit/Magit-Popup? Uninstalling and reinstalling these packages with the Emacs version that you are actually using should fix the issue.
    – tarsius
    Jun 3, 2018 at 2:32
  • That's it! I use a sync'd directory to keep my emacs config up to date on half a dozen systems. I guess I need to rethink that a bit. Homebrew on macOS updated to emacs 26. I need to find a PPA that has emacs-26 for my Ubuntu systems. Jun 4, 2018 at 12:14
  • Instead of adding a [SOLVED] suffix, you should accept an answer. This is how questions are marked as solved here. You could also add your own answer and accept that, if you feel it is necessary to provide the additional information provided by your and my comments but that is not include in Stefan's answer.
    – tarsius
    Jun 4, 2018 at 17:03
  • @tarsius Thanks for the pointer. I had seen [SOLVED] on another post so assumed that was the correct way. Although I don't see a way to accept Stefan's answer?? Jun 5, 2018 at 18:14
  • On the right of his answer there are three circular buttons and a number. Click on the button at to buttom - the one that looks like a check mark.
    – tarsius
    Jun 26, 2018 at 7:59

1 Answer 1

3

Agreed with tarsius: you probably have some package that was compiled with Emacs-26. Make sure your packages are compiled with the older Emacs, since that's the direction for which we try to preserve compatibility.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.