0

When I open a file with extension .plt, emacs behaves in a strange way. For example, I cannot type a space. I believe it has to do with something called the "PLT Package" because that name is displayed at the bottom of my window. However, no such package is listed in my .emacs file or in the list of packages accessible through emacs' menus.

I would simply like to remove/disable this package.

PS: In response to the suggestions so far, here is a screenshot that seems to indicate that "PLT Package" is related to a major mode.

enter image description here

2
  • Gnuplot files are often named .plt. Jun 18, 2018 at 16:21
  • what version of emacs and where did you get it from?
    – dcorking
    Jun 19, 2018 at 14:16

1 Answer 1

1

Emacs has no special behaviour for the .plt file extension by default, so you have most likely added this library in your own config.

Assuming it is a major mode, I suggest using M-: (find-function major-mode) RET in the buffer to locate the library which defines it, which you could then delete (along with any other custom config you have relating to that library).

Make sure you delete the byte-compiled .elc file too, if one exists.

5
  • Thanks. Doing what you suggest takes me to the file lisp-mode.el.gz. Is that not a standard component of emacs? Jun 18, 2018 at 14:33
  • It sure is. "PLT Package" clearly isn't the major mode in that buffer (that was a guess on my part, as it wasn't obvious from your question), so most likely it is a minor mode. Type C-h m in the buffer and look for something related in the list of minor modes at the top. The following might tell you: M-: (car (cl-member " PLT Package" minor-mode-alist :key 'cadr :test 'equal))
    – phils
    Jun 18, 2018 at 22:16
  • That said, it's curious to me that your .plt buffer must have been in lisp-mode (being the only major mode defined in lisp-mode.el). That may give you further information. Perhaps just use C-h v auto-mode-alist and search with C-s for plt -- if your config is picking up on the file extension, it should be configured in there.
    – phils
    Jun 18, 2018 at 22:31
  • 1
    Thanks! C-h m brings out "PLT Package mode defined in `quack.el': nil". C-h v auto-mode-alist gives " ("\\.plt\\'" . quack-pltfile-mode)". So how do I disable quack? Jun 19, 2018 at 10:22
  • just delete quack.el and quack.elc and remove the config the way phils described (Are you using Debian? In which case, quack comes along with many other useful tools, in emacs-goodies-el packages.debian.org/stretch/emacs-goodies-el . The config is probably in /etc/emacs/site-start.d/50emacs-goodies-el.el )
    – dcorking
    Jun 19, 2018 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.