0

I have fresh new installation of emacs altogether with spacemacs. I set env vars for alternate editor and server file. My server file after starting emacs looks like:

127.0.0.1:64518 11948
'M.P$#NT[Q~>U`12i^zhRdA0#B&HJ`7T-9.{G`tl%M+|?l4sE2gGt8w|Aao0:,.O

However, if I'm trying to run emacsclient.exe (the same for emacsclientw.exe) I get a new emacs frame. What am I doing wrong? What shall I check in order to diagnose the issue?

  • Can you access buffers and files open from another server frame? If so, you've set things up correctly. – DoMiNeLa10 Jun 21 '18 at 16:02
  • It could be that some virus scanner blocks the tcp/ip connection. You could try to deactivate the virus scanner temporarily. Maybe a firewall could also cause such a problem. Even if there exists a server file is the server really running? You could try M-x server-start. That should restart the server. – Tobias Jun 21 '18 at 17:49
  • @tobias how to check without switching my firewall that the cause is there? is there any debugging messages in emacs itself? – Georgy Grigoryev Jun 22 '18 at 7:55
  • @GeorgyGrigoryev That's a difficult one. If the server does not get any connection what should he tell you? So there is not really any debugging. Just disconnect your computer from the internet and switch off the firewall. – Tobias Jun 22 '18 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.