1

In markdown mode, all of the fenced code blocks and inline code literal strings are displaying with this very large font. The size is large, and also I'm pretty sure it isn't the same font as the default surrounding text (which is Classic Console).

enter image description here


This is Emacs 25.3 on a Mac, using the standalone app (the one from https://emacsformacosx.com/).

My .emacs file is here.

  • 1
    Are you asking why the default font sizes are thus? If so, ask the library author. Or are you asking why your customizations give font sizes like this? If so, bisect your init file to find out. Or are you asking something else? The question is unclear. Please don't just give a link to your init file and ask people here to tell you why you get what you get from your customizations. – Drew Jun 29 '18 at 3:17
  • If you like the built-in customization features to change the appearance of something, then place your cursor at the location of whatever you want to change and type M-x customize-face. If there is more than one thing happening at the particular location at issue, type C-u C-x = and read about what's there to determine what things you may wish to customize. – lawlist Jun 29 '18 at 3:47
1

This can be fixed by calling M-x customize-group RET markdown-faces while in Markdown mode. It opens a menu of various font face settings. Under Markdown Code Face, uncheck/delete everything and then save. This will make the code face the same as the default face.

0

In addition to Adam Michael Wood and lawlist:

C-u C-x = - good way to get information about font symbol

Information about symbol's font

In appered buffer you should follow that paragraph: There are text properties here: and visit highlighted link. This way can help you look through font inheritance.

You can get clear that Mardown Code Face inherits Emacs system fixed-pitch root-font.

Fixed pitch font options

(customize this face) - Opens Emacs font editor

Or you can change this settings in your .emacs file

(custom-set-faces
 '(default ((t (:family "Ubuntu Mono" :foundry "DAMA" :slant normal :weight normal :height 107 :width normal))))
  )

Append next line after default font:

 '(fixed-pitch ((t (:family "Ubuntu Mono"))))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.