4

I am working in a cluster environment, where the default emacs version is 24.3. Unfortunately spacemacs support only from >24.4. Administrators refuse to update the version. They asked me install my own emacs using conda. I did that. But, for some reason I am not able to get the spacemacs working. I am not able to change font. Its not recognising the system fonts at all. Also, the display gets scrambled often like the one in the picture. enter image description here

  • 2
    Just compile it yourself. You should be able to find instructions all over the place in the internets. In the case that you don't have admin rights, the easiest route is to create a virtual box with the same operating system and compile it there then copy the emacs binaries. See this question. – dangom Jul 3 '18 at 23:58
  • 1
    I have been working with a spacemacs on 24.3 for a long time, but some auto-update made it no longer start error: Your version of Emacs (24.3.1) is too old. Spacemacs requires Emacs version 24.4 or above.. Kind of brain-dead that it updates itself to a version no longer supported by the emacs it runs on. Better stop the updates in that case. (And it would be good to be able to install an older version as you indicate). – Anthon Jul 4 '18 at 14:19
2

As a workaround, if you are on the 0.200 series (current master branch) you could locally revert commit efba1fe6bb333416aeb3ca4209689575d73211f4 and disable the auto-update feature (which I think it will be broken if there are local commits on the repository)

There's no guarantee that your spacemacs will work properly, because the error is there for a reason. However, it might work just fine for the features you use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.