2

I'm a noob in Emacs org mode. I convert a note of my friend's from .lyx to .tex with lyx then I use pandoc to convert it into .org. As default under heading I find:

:PROPERTIES:
:CUSTOM_ID: title-of-chapter
:END:

But when i run C-c C-e l p to interpret with LaTeX I found ":CUSTOM_ID: title-of-chapter" rendered as pdf. What's happening?

1

To stop the export of drawers in general, or property drawers in particular, you can add an options line to your file:

#+OPTIONS: d:nil prop:nil

You can also set the corresponding variables in your init file and make those settings permanent:

(setq org-export-with-drawers nil)
(setq org-export-with-properties nil)

I would recommend that you NOT do the latter: it will create problems in the future after you have forgotten all about the setting and you absolutely need to export a property drawer. The #+OPTIONS setting is much more flexible IMO.

1
  • thank you NickD. It works, also I change all CUSTOM_ID:yada-yada to <<yada-yada>> and seems to works well. – acidwinzip 77 Jul 6 '18 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.