0

Running emacs 25.2.2 with evil installed and updated from Melpa.

When I run ediff, it asks for usual buffer A and buffer B and then ONLY the ediff buffer in its own frame is visible with 'Type ? for help'. I can switch to the other emacs frame where the two files are shown as expected. But none of the ediff commands work.

Earlier (without evil) ediff showed a nice three window setup with two buffers on top and ediff control buffer at the bottom.

How do I get that behavior back?

1

M-x customize-option RET ediff-window-setup-function RET

Select "Single Frame".

(Much better than the default, IMHO; especially in a tiling window manager, where the multi-frame config is all but unusable.)


I can't fathom why evil might be poking its nose into that configuration, mind you. If that actually turns out to be the cause, I would report it as a bug. Note that the multi-frame config is the default for GUI frames, though; so maybe it's the other way around, and something which used to set the single-window config is now refraining from doing so.

  • Thanks. That was perfect. I am using KDE Plasma. But single frame is much better than the default, I agree. And no, even with evil ediff now behaves as expected. So I guess it was about setting that option :) – deshmukh Jul 21 '18 at 0:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.