I want to remove a white border of the tabbar.

enter image description here

(The strange color choice is only for checking the configuration of faces.)

As you can see, the right part of tabbar has a white border and I can not change its color from the tabbar's set-face-attribute.

After some tries I have found that the reason of the border comes from afternoon theme. But I can not figure out which setting I should modify el-file.

How can I remove the border or change its color?

(load-theme 'afternoon t)

(require 'tabbar)

(setq tabbar-buffer-groups-function nil)
(dolist (btn '(tabbar-buffer-home-button
  (set btn (cons (cons "" nil)
             (cons "" nil))))
(setq tabbar-separator '(1.5))

;; face settings (has no effects on the border...)
 'tabbar-default nil
 :family "Noto Sans"
 :background "darkgreen"
 :foreground "gray80"
 :box nil
 :height 1.0)
 'tabbar-unselected nil
 :background "darkred"
 :foreground "gray80"
 :box nil)
 'tabbar-selected nil
 :background "darkblue"
 :foreground "SkyBlue1"
 :box nil)
 'tabbar-button nil
 :box nil)
 'tabbar-separator nil
 :height 1.2)

(tabbar-mode 1)

EDIT. If I comment out the line for afternoon, the white border disappeared.

enter image description here

  • openSUSE Leap 15.0
  • Version 25.3.1 (x86_64-suse-linux-gnu, GTK+ Version 3.22.30)
  • My notes indicate that tabbar-default is indeed the llikely suspect, so you might want to type M-x customize-face ... and see if your theme is modifying your preferred settings. The only other thing I can think of is to make sure that tabbar-background-color is nil. – lawlist Jul 29 '18 at 16:00
  • I also thought so. But any setting for tabbar-default does not seem to work for the border. I can change only the background color. – H. Shindoh Jul 29 '18 at 16:25
  • There are only three likely :box suspects in the theme that I can see: (1) github.com/osener/emacs-afternoon-theme/blob/master/… ; (2) github.com/osener/emacs-afternoon-theme/blob/master/… ; and, (3) github.com/osener/emacs-afternoon-theme/blob/master/… . However, I didn't find those inside my version of tabbar.el. Perhaps your particular build of Emacs uses widget-field, or something you are using is inheriting mode-line or mode-line-inactive .... – lawlist Jul 29 '18 at 17:31
  • Thanks! The second one is bingo. Namely the tabbar uses the face of (active) mode line. If I remove :color ,foreground, the white border is "removed" and the border-color around the file name in the mode line becomes purple. – H. Shindoh Jul 29 '18 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.