1

In spacemacs, I want SPC p f to ignore one directory in the files it suggests. I followed the Projectile docs for ignoring files. I added a line to both my ~/.emacs.d/.projectile file and the .projectile file in the root of the project. None of the following seem to work for ignoring a folder:

-.folder -.folder/** -**/.folder -.folder/**/*

(note that the folder to ignore does have a . in its name)

Am I missing some reindex command? I tried SPC p I which did something, but didn't fix this problem. Closing and opening Emacs did nothing.

1

Take a look at this answer, which I report entirely here

if you want to use .projectile list of ignored files, you should try with

(setq projectile-enable-caching t) (setq projectile-indexing-method 'native)

... inside your config file. It looks like ignoring by .projectile list is currently working with native indexing method. More details: in github . With alien method .gitignore is working well (but alien is not respecting .projectile list).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.