0

This is convoluted.

I am calling company-jedi which calls company-begin.

Looks like company-mode does a check with TRAMP first,

I get this in messages:

Company: An error occurred in auto-begin
Not a Tramp file name: "/Workspace [bazel]: /home/edgar/some_repo/ros
Rosbag: Saving bag file LOCALLY to /home/edgar/data/ext_dsshare/emacs/site-lisp/"
user-error: Cannot complete at point

So it looks like I need to change/use tramp-file-name-regexp to avoid this path and for that I would like some help/if anyone has other ideas.

  • 1
    I don't recommend to change tramp-file-name-regexp, it would result in collateral damages if you use ever Tramp. Better would be to set tramp-mode to nil, this disables Tramp. Whether company-mode cares about this option is unknown to me. – Michael Albinus Aug 7 '18 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.