0

After upgrading to Emacs 26, I have been having a problem when flyspell checks a document in Spanish. More precisely, flyspell doesn’t recognize accents and erroneously considers accented words like “musica” as two words (“mús” and “ica “). It doesn’t seem to be a problem with the dictionary, since I’ve made sure that the “castellano8” Spanish dictionary is loaded. Indeed, when I spellcheck the buffer (with aspell) it correctly recognizes accents. Does anybody know what changed with Emacs 26 (Emacs 25 didn’t have this problem), and how could this issue be resolved?

1
  1. If you use hunspell, see Hunspell error in emacs

  2. If you use aspell,the dictionary package aspell-es should be installed ( I'm not sure castellano8 is right dictionary for aspell).

Even you are confident you've already installed and setup the right dictionary, it never hurts to double check by running echo whateverword | aspell -a --sug-mode=ultra --lang=es in shell.

Here is the minimum setup for aspell,

(setq ispell-program-name "aspell")
;; Please note ispell-extra-args contains ACTUAL parameters passed to aspell
(setq ispell-extra-args '("--sug-mode=ultra" "--lang=es")))

Besides, make sure that --run-together option is not passed to aspell. If you are not sure, add --dont-run-together to ispell-extra-args.

  • Thank you very much for your prompt reply, and for your suggestions. First of all, I am using aspell, The dictionary castellano8 seems to exist (and it works when I spell check the buffer), but somehow it's not the right one for flyspell, as you suggested. In fact, changing "castellano8" to "castellano" solved my problem! – user3476591 Aug 7 '18 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.