1

I'm running emacs in my full screen gnome terminal (version 3.28.2) on Ubuntu 18.04.1 using emacs -nw but am struggling to get the frame to fit the entire screen. Here is a picture of my terminal, which as you can see fills the entire screen:

Terminal window

However when emacs is open you can see the terminal around the bottom and right-hand edges (see picture of my init.el file open in emacs below)

My init.el file with (setq frame-resize-pixelwise t) in it already

As you can see in my init.el file, I have tried to put (setq frame-resize-pixelwise t) as suggested in this thread: Emacs theme not covering up the entire terminal window. The Ubuntu purple terminal background is showing on the edges to no avail. I have also read this post: Emacs not taking full space inside terminal which I realise is essentially a duplicate (sorry) but hasn't, in my opinion, been adequately answered (the suggestion about theme fringes being a different colour seems wrong because it's clearly my terminal theme around the edges). Any help would be great.

  • It could be the terminal which doesn't report its width correctly... or maybe that stripe on the right is not actually the terminal, just a decoration which looks like it's part of the terminal? – wvxvw Aug 12 '18 at 19:44
  • Pretty sure it's not a decoration because the strip on the right changes colour when I change the theme of my terminal. If it is my terminal not reporting its dimensions properly, will that be an issue fixed through gnome terminal settings and not emacs? – ahi94 Aug 12 '18 at 23:04
  • Can you try different terminals to see if that's not an issue with Emac's geometry calculation, but rather with the input it gets from the terminal? I still suspect that that orange bar is some kind of, well, I don't know, a margin, a space added by terminal to make it visually uniform... in normal operation, can this space be used by actual terminal's output? What if you run some curses programs, are they able to use that space? (I think aslamixer paints the entire console, if not that, then try mc). – wvxvw Aug 13 '18 at 6:18
  • Hi - I tried it in guake terminal and had the same issue - by the way I should have clarified the orange bar on the right is the terminal scroll bar. I've disabled it now so that's gone but the problem still remains. So I tried typing to the end of the line on my shell and there is a small section that doesn't get used on the right. I tried mc and that leaves the same small stripe at the top and bottom but not the weird bottom RH corner like on emacs. – ahi94 Aug 14 '18 at 14:48
  • I had same problem, I solve this by setting the theme of both Emacs and terminal to be dark just so it doesn't distract or annoy me. I have no technical solution unfortunately – Sigu Magwa Aug 14 '18 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.