I'm using Emacs 24.5.1, and my org-export-dispatch doesn't show "Export to ODT" by default. However, if I use M-x org-odt-export-to-odt, it works fine and the option is shown on the next dispatch.

How can I make the "Export to ODT" option permament without having to call org-odt-export-to-odt first?

1 Answer 1


The org-export-backends variable contains the backends that should always be available. In Emacs 24/Orgmode 8, it will be (ascii html icalendar latex), which is why the ODT options aren't shown.

You have to customize the variable, e.g. M-x customize-option RET org-export-backends RET:

Org Export Backends:
[X]    ascii       Export buffer to ASCII format
[ ]    beamer      Export buffer to Beamer presentation
[X]    html        Export buffer to HTML format
[X]    icalendar   Export buffer to iCalendar format
[X]    latex       Export buffer to LaTeX format
[ ]    man         Export buffer to MAN format
[ ]    md          Export buffer to Markdown format
[ ]    odt         Export buffer to ODT format                <-----------
[ ]    org         Export buffer to Org format
[ ]    texinfo     Export buffer to Texinfo format
[ ] C  confluence  Export buffer to Confluence Wiki format
[ ] C  deck        Export buffer to deck.js presentations
[ ] C  freemind    Export buffer to Freemind mindmap format
[ ] C  groff       Export buffer to Groff format
[ ] C  koma-letter Export buffer to KOMA Scrlttrl2 format
[ ] C  RSS 2.0     Export buffer to RSS 2.0 format
[ ] C  s5          Export buffer to s5 presentations
[ ] C  taskjuggler Export buffer to TaskJuggler format

Keep in mind that the variable must be known, so you might need to enable org-mode at least once.

Note that Emacs 25 provides ODT as default export. Unless you're stuck on Emacs 24 I recommend you to update your installation.

  • 1
    You can also (require ox-odt). A strong +1 on the upgrade recommendation: org 8 is obsolete.
    – NickD
    Aug 20, 2018 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.