The day before yesterday, I have experienced my Ubuntu package ess (Version: 17.11-3bionic0) no more configuring properly during apt-get update. I then tried apt-get install -d ess and:

dpkg -i /var/cache/apt/archives/ess_17.11-3bionic0_all.deb 

I get:

Preparing to unpack .../ess_17.11-3bionic0_all.deb ...
Remove ess for emacs25
remove/ess: purging byte-compiled files for emacs25
Unpacking ess (17.11-3bionic0) over (17.11-3bionic0) ...
Setting up ess (17.11-3bionic0) ...
Install emacsen-common for emacs25
emacsen-common: Handling install of emacsen flavor emacs25
Install ess for emacs25
install/ess: Handling install for emacsen flavor emacs25
ERROR: install script from ess package failed
dpkg: error processing package ess (--install):
installed ess package post-installation script subprocess returned error exit status 1
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Errors were encountered while processing:

I am using Ubuntu 18.04 with GNU Emacs 25.2.2.

Looking in the emacs package manager, it says:

  ess                17.11         incompat   melpa-s... Emacs Speaks Statistics

So, it seems that the package from melpa is uninstallable because of being incompatible with my current Ubuntu emacs version, and the Ubuntu package of the same version can neither be installed.

I have tried this solution from Ubuntu SX but it didn't work for me.

What else can I do now?

Thank you for your help.

  • Can you try downloading the DEB package without installing it (use -d option with apt-get) and then install it with dpkg? This would give a better error message.
    – wvxvw
    Aug 21, 2018 at 11:45
  • Did that, does not seem to be much more informative.
    – mfg
    Aug 21, 2018 at 12:32
  • A solution to the problem is posted under "ESS install fails for Ubuntu 18.04".
    – B. Dorazio
    Aug 21, 2018 at 17:59
  • I'll have to look at it when I'm back in the office.
    – wvxvw
    Aug 21, 2018 at 18:49
  • Thx, I just found out.
    – mfg
    Aug 21, 2018 at 20:01

1 Answer 1


For sake of completeness. A look at ESS on GitHub or r-sig-debian required me to download:



and to install them via:

dpkg -i ess_17.11-4_all.deb elpa-ess_17.11-4_all.deb

Works for me on 18.04.

Edit: The CRAN repository has been updated accordingly. So, the above procedure is now only needed if you do not want to use the package manager for this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.