0

I had previously installed and used Emacs 25.2.2 and ESS 17.11 on Ubuntu 18.04 (Bionic Beaver). While attempting to update to the latest version of ESS, the ESS install script appears to have failed (see terminal output below).

I tried removing (with --purge) and then re-installing both ESS and Emacs 25, but this did not solve the problem.

Does anyone have a solution to this problem?

dorazio@toucan:~$ sudo apt install ess
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  xlispstat pspp jags julia
The following NEW packages will be installed:
  ess
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,341 kB of archives.
After this operation, 5,776 kB of additional disk space will be used.
Selecting previously unselected package ess.
(Reading database ... 376257 files and directories currently installed.)
Preparing to unpack .../ess_17.11-3bionic0_all.deb ...
Unpacking ess (17.11-3bionic0) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up ess (17.11-3bionic0) ...
Install emacsen-common for emacs25
emacsen-common: Handling install of emacsen flavor emacs25
Install ess for emacs25
install/ess: Handling install for emacsen flavor emacs25
ERROR: install script from ess package failed
dpkg: error processing package ess (--configure):
 installed ess package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 ess
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • FWIW, this is a bug in packaging and is only peripherally related to Emacs, so the best thing to do is to report it to Ubuntu. – Stefan Aug 22 '18 at 20:37
  • 1
    It seems to be more than a bug in packaging. The revisions of ESS version 17.11-2 had unintended consequences for Linux users. The problem has been fixed, and the Ubuntu repository has been updated. – B. Dorazio Aug 23 '18 at 15:09
  • Do you get the same problems installing it via M-x package-install ess? That will install it from the official Emacs (M)ELPA repos. Then do M-: (require 'ess) to enable it. Then do M-x ess to start it. (I'm going from memory on how to enable/start it, so YMMV). – Lorem Ipsum Nov 21 '18 at 18:22
0

Bill Venables encountered the same problem and posted it on github as follows:

"An automatic upgrade to ess_17.11-3 on Ubuntu 16.04 has failed, killing ess. The installation script failed with error code 1, without much further information that I can see. This is for Emacs 24. The result was no working ess functionality at all on Emacs.

Purging ess_17.11-3 and manually re-installing ess_17.11-2 worked fine, though.

The same problem with the same killing effect also happened on Ubuntu 18.04 LTS (bionic) with Emacs 25. I have yet to check if re-installing ess_17.11-2 works in that case, but I suspect it shall."

Apparently the bug in the install script has been reported to the r-sig-debian list.

In the meantime, one solution to the problem is to purge ess_17.11-3 and then to manually reinstall ess 17.11-2 from its deb file. This worked for me using Emacs 25.2.2 on Ubuntu 18.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.