0

It appears that I've also lost the ability to use Emacs Org basic table editing commands. For example, when I start a table with a | and add the column headings then hit TAB, Emacs returns the same message: Symbol’s value as variable is void: org-enable-table-editor.

  • That might mean that the library (file) where variable org-enable-table-editor is defined has not been loaded. Or it might mean that you are trying to evaluate a function symbol with that name as if it were a variable. If it is a function then you invoke it by (org-enable-table-editor ...) or by passing that symbol to funcall or apply. – Drew Sep 1 '18 at 22:51
  • org-enable-table-editor was removed from the code base a year ago. The new code base that you got with the new version probably does not know about it. The question is why your setup is looking for it: one possibility is that you use it explicitly in one of your initialization files; the other is that you have a "mixed" installation. Are you using the org-mode that comes with emacs? What version of emacs are you running (M-x emacs-version)? What version of org-mode (M-x org-version)? – NickD Sep 2 '18 at 0:10
  • GNU Emacs 25.2.2 (x86_64-pc-linux-gnu, GTK+ Version 3.22.21) of 2017-09-22, modified by Debian; Org mode version 9.1.6 (9.1.6-dist @ /home/go/.emacs.d/elpa/org-20160321/). When I load emacs without my initialization file, the table editor commands work. I'll have to dig through my init routine and find what's causing the problem. – tempestcat Sep 2 '18 at 0:42
1

The org version (elpa/org-20160321) I was using contained org-enable-table-editor and it was 'removed from the code base a year ago'. I tried to remove it using list-packages but due to dependencies it wasn't removed. I read from a comment in https://stackoverflow.com/questions/20541322/how-to-remove-installed-elpa-package that it should be fine to delete the elpa package and package-initialize will resolve any dependencies.

org table works fine now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.