1

windows 10, emacs 26.1, icicles

Before Icicles when I type C-x C-f is show list of folders/files in ido mode. And it's very comfortable for me.

But after I install Icicles and turn on icy-mode the ido mode is gone (e.g. when I type C-x C-f). Is it normal? Now is show Icicles candidates to complete. OK, but I want to work with ido mode. Is it possible?

  • 1
    I'm not really surprised because icy-mode and ido-mode solve the same problem. No wonder there's a conflict. – wasamasa Sep 5 '18 at 16:56
1

Please take a look at the Icicles documentation. Section Icicles - Ido and IswitchB covers this.

It tells you, for example, "You cannot use Icicles and Ido together, however – they use the minibuffer in incompatible ways."

However, you can use Icicles and Icomplete together. Icomplete shows you completion candidates in the minibuffer (and lets you choose them) in a way similar to Ido.

Icicles - Ido and IswitchB also tells you how you can get more Ido-like behavior while using Icicles. There are different parts of Ido behavior that you can obtain, with respect to: incremental completion, non-expansion of minibuffer input, matching, cycling and sorting, current candidate, editing input, display of completions, auto-choice of single candidate, and more.

That page also tells you that to get Ido-like behavior for files (your C-x C-f example) you just need to customize option icicle-files-ido-like-flag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.