0

Windows 10 (64 bit), Emacs 26.1

I open trace.log file from remote Linux machine by Tramp mode.

Nice.

I set custom variables:

'(password-cache-expiry nil)
'(auto-revert-remote-files t)

I set variable auto-revert-remote-files t because I need to see content of remote file interactively (on fly).

But when file trace.log is change (by external web application) I get the next message in minibuffer:

Tramp: Waiting for prompts from remote shell...done
Copying /pscp:mylogin@remote_ip_machiney_ip:/root/logs/trace.log to c:/Users/Alex/AppData/Local/Temp/tramp.2iBhRe.log...done
Tramp: Inserting ‘/ppscp:mylogin@remote_ip_machiney_ip:/home/myproject/logs/trace.log’...done

    Tramp: Checking ‘vc-registered’ for /pscp:mylogin@remote_ip_machiney_ip:/root/back/myapp/logs/trace.log...done
    Tramp: Inserting ‘/pscp:mylogin@remote_ip_machiney_ip::/root/back/myapp/logs/trace.log’...done

File trace.log on remote machine is periodically changes by web application.

How disable this message on minibuffer?

0

If you want the messages to disappear from your minibuffer, decrease the value of tramp-verbose. 1 means to display only error messages, 0 suppresses Tramp messages at all.

However, I don't understand why you see such messages. If you visit a (remote) file in a buffer, nothing will happen if the file changes externally, as long as you don't try to write. What makes these messages appear in your minibuffer? How did you load the remote file?

  • I open remote file via Tramp mode. Like this: /pscp:my_login@my_ip:/home/my_app/ – a_subscriber Sep 19 '18 at 7:29
  • Do you have enabled something like (global) autorevert? – Michael Albinus Sep 19 '18 at 7:35
  • Yes, I set '(auto-revert-remote-files t). I set this variable because I need to see content of remote file interactively. – a_subscriber Sep 19 '18 at 8:00
  • Well, this is the reason why the file is reloaded. So I recommend to disable auto-revert-mode for this file, if you want to have it reloaded once a day only. This could be done manually. – Michael Albinus Sep 19 '18 at 8:29
  • 1
    Then you must decrease the value of tramp-verbose as described in my answer. BTW, a better way to see the contents of a log file is to apply auto-revert-tail-mode instead of auto-revert-mode. – Michael Albinus Sep 19 '18 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.