0

windows 10, emacs 26.1

Here dired in summary mode:

enter image description here

If I want to show detail I press ( and here result:

enter image description here

Nice. But I want always to show dired in details. So I set this variable:

 '(global-dired-hide-details-mode nil)

but it not help. It always show dired in summary mode.

  • 1
    The vanilla Emacs's Dired doesn't enable the buffer-local mode dired-hide-details-mode by default. So you need to figure out how you did it (a common way is (add-hook 'dired-mode-hook 'dired-hide-details-mode)) then undo it. And there is no global-dired-hide-details-mode. – xuchunyang Sep 22 '18 at 9:21
  • Sorry it was because was start dired plus package. If disable it, then dired mode show , by default, show details info. – Alexei Sep 22 '18 at 9:50
2

As comments have indicated, in vanilla Emacs Dired does not hide details by default. But Dired+ does hide details by default.

If you want to use Dired+ and you want to show details by default then just customize option diredp-hide-details-initially-flag. That's what it's for: to give users control over the initial behavior.


See also option diredp-hide-details-propagate-flag:

Non-nil means display the next Dired buffer the same way as the last.

The last dired-hide-details-mode value set is used by the next Dired buffer created.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.