1

I just updated to Mojave. I used to use emacs-mac from https://bitbucket.org/mituharu/emacs-mac/ but with Mojave I just get blank window for emacs. I also tried emacs-plus and building on my own both which had the same issue.

The installation from https://www.gnu.org/software/emacs/ and emacs in the terminal seems to work fine. But I need dvisvgm support which neither has.

Please let me know if you would need more information.

HELP!

  • Hmmm ... Mojave was released to the public a few hours ago ... What are the chances that anyone has had a chance test Emacs compatibility ... and/or implement fixes ...? Your best bet would be to open an issue with Mitsuharu Yamamoto .... since that author is already advertising: "This provides a native GUI support for Mac OS X 10.6 - macOS 10.14." – lawlist Sep 25 '18 at 6:27
  • Just curious, how is dvisvgm integrated into the Mituharu san:s version of Emacs? Can it display dvi files in Emacs windows? Is this something for the official Emacs to adapt? – Lindydancer Sep 25 '18 at 14:58
  • 1
    FWIW, I have been running the Mojave beta for weeks. After installing it, I compiled emacs-mac from source (git clone https://bitbucket.org/mituharu/emacs-mac.git), and it worked fine. But then, I am used to this, having compiled emacs on my own “forever”. It's one of very few software packages I regularly compile myself. – Harald Hanche-Olsen Sep 26 '18 at 7:00
  • Alan Third pushed a commit to the master branch of vanilla Emacs on 09/28/2018: 7946445962372c4255180af45cb7c857f1b0b5fa . I don't have a computer running Mojave, but anyone wanting to give the new patch a try might want to check out the current master branch. – lawlist Oct 1 '18 at 1:02
  • 1
    Glad you got it to work. This kind of thing is not too unusual when upgrading an OS; it's probably not worth your time to try to get to the bottom of it. BTW, in the interest of housekeeping: If you add a brief answer, saying how you got around the problem, and then accept that answer, this question won't hang around on the site forever as an unanswered question. – Harald Hanche-Olsen Oct 1 '18 at 9:42
1

I did a fresh installation of mituharu's version (https://bitbucket.org/mituharu/emacs-mac/) using brew and now everything works. I had to remove the older version of emacs that I had before starting the installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.