0

I have a project on my windows machine. I mounted that via samba. Then I access the project with spacemacs. When I run magit now all project fiels have been modified.

The actual change is that every file has a line feed with ^M now.

How can I disable this?

  • Were there any files you did not explicitly edit that were changed? Does the following help? gnu.org/software/emacs/manual/html_node/emacs/… – Croad Langshan Sep 26 '18 at 19:30
  • Tried that already. Not working. Yea all files of the whole project where modified with the ^M. So in fact all are true to your question – xetra11 Sep 26 '18 at 19:34
1

This is more of a Git issue than an Emacs/Magit issue. Git provides several variables to control this: core.eol, core.safectlf and core.autocrlf, all documented in git-config(1). Also ask a search engine about "git line ending" or something like that.

Here are some pages I found that way, that seem to provide easy to follow instructions:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.