1

I am trying to get Solarized theme color correct in terminal by enabling truecolor on my Mac, following the instruction from Spacemaces: https://github.com/syl20bnr/spacemacs/wiki/Terminal.

But I got error when I set TERM=xterm-24bit:

$ TERM=xterm-24bit
zsh: can't find terminal definition for xterm-24bit

I also tried to put compiled terminfo into /usr/share/terminfo, not working.

I also tried to set TERMINFO to $HOME/.terminfo, not working.

I am using iTerm2 3.2.1, Emacs 26.1, macOS 10.14 and Spacemacs.

1

It turns out to be a problem with the tic I use.

Because I installed latest miniconda and included it in PATH, so when I run which tic I got /Users/Yuji/miniconda/bin/tic. Once I changed to use system tic, problem solved. Here is the code:

/usr/bin/tic  -x -o ~/.terminfo  xterm-24bit.terminfo

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.