0

Exporting to Latex PDF does not add a newline at the end of headings level 4.

Source:

* My one
** My one one
Plain text
*** my one one one
Plain text
**** my one one one one
Plain text
** My one two

Latex pdf output, see the inner heading, level 4:

enter image description here

I've read about org-blank-before-new-entry, but it looks like I'm looking for something after new entry of level 4.

Observing the generated LaTeX source, it turns out that level 4 is implemented by a \begin{enumerate} \item, that explains it.

How can I make org-mode add a newline after a header of level 4 or more?

1

You probably want to increase the maximum heading level when exporting.

See the H: directive for export settings.

In your case, level 4 is treated as a list item. Increasing H: will give you deeper heading levels.

  • I don't think that works for LaTeX, which appears to be limited to three levels – rpluim Oct 3 '18 at 13:04
  • 1
    Not really, but you have to adjust other things as well, e.g. you might have to modify the org-latex-classes settings and/or the latex class that you are using (book, report and article behave differently). – NickD Oct 3 '18 at 14:46
  • In case it isn't clear, my previous comment was a reply to the comment by @rpluim. – NickD Oct 3 '18 at 20:04
  • I should have said "just setting H: on its own doesn't work for LaTeX". I'd be interested if you could add those "other things" to the answer. – rpluim Oct 4 '18 at 7:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.