0

Looking at this answer, I found out that if you use TeX entry mode, you can just type \lambda and have it convert to λ on the fly, which is super helpful. However, when I tried doing \coloneqq, I didn't get ⩴ (U+2A74). Presumably, this is because the mapper doesn't know about symbols in other packages other than some default set.

How do I manually add support for more commands? I'd expect that the "hints" work with the new commands as well; presently, if I type \lamb, then the gutter shows \lamb[d].

After going through the different TeX related groups, it looks like I need to modify the LaTeX-math-list variable but I don't really understand the docs there:

KEY is the key (after ‘LaTeX-math-abbrev-prefix’) to be redefined in math minor mode. If KEY is nil, the symbol has no associated keystroke (it is available in the menu, though).

VALUE can be a string with the name of the macro to be inserted, or a function to be called. The macro must be given without the leading backslash.

The third element MENU is the name of the submenu where the command should be added. MENU can be either a string (e.g. "greek"), a list (e.g. ("AMS" "Delimiters")) or nil. If MENU is nil, no menu item will be created.

The fourth element CHARACTER is a Unicode character position for menu display. When nil, no character is shown.

Do I modify this? Could you give an example of what needs to be done? Or do I modify LaTeX-math-menu? Currently LaTeX-math-menu's value looks like:

Value: ("Math"
  ["Cal-whatever" LaTeX-math-cal t]
  ("Greek Uppercase"
  ["Γ \\Gamma" LaTeX-math-Gamma t]
  ["Δ \\Delta" LaTeX-math-Delta t]
  ...

However, LaTeX-math-Gamma etc. are not actually defined.

Additional info: I'm using Spacemacs with the latex layer, with no (La)TeX specific settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.