2

I have installed emacs 24.3 from source on CentOS 6.9.

I configured, compiled and installed it with:

./configure --prefix=$HOME/install --with-xpm=no --with-gif=no --with-tiff=no make make install

The unreadable characters appear in the bottom bars as well as the buffers.

Same issue with emacs-24.5

enter image description here

  • Since you're installing from source anyways, is there a reason you're using version 24 instead of the latest version, 26? – Tyler Oct 12 '18 at 17:08
  • 1
    The error message looks like something related to faces. Do you have any init file? Have you tried running emacs-Q? If the error persists, please copy it and add it to the answer. – DoMiNeLa10 Oct 12 '18 at 17:48
1

As DoMiNeLA10 suggested, it was related to faces in my init file. Removing that solved the problem in my system.

The line causing the issue was: (set-face-attribute 'default nil :family "Menlo" :height 120)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.