0

I run emacs from my xfce4 (version 0.8.7.4) terminal on my Linux machine. When I applied the atom-one-dark-theme, I noticed that below the information bar it did not apply that colouring of the theme there. See screenshot below:

enter image description here

As you can see there is a white border at the bottom. Is this an issue with my terminal or is it an issue with the theme? I noticed in these screenshots that there should be no gaps in the colouring.

  • That just looks like padding your terminal adds to me. I'm assuming it's there because you're using a maximized window, and terminals have to resize by characters rather than pixels. You can clearly see your minibuffer below the mode line, that's the bottom line of the terminal. It looks like your theme is applied correctly. The only way I can think of to prevent this from happening is to run graphical emacs and set it to resize by pixels. – DoMiNeLa10 Oct 14 '18 at 16:38
  • 1
    Yeah you are right. I switched to the graphical version of emacs and I don't get the problem. – user12201 Oct 14 '18 at 17:05
1

The theme is applied right. The white lines you see between the borders of your window and actual content are there because terminals resize in character sized increments rather than pixels, and you're in a maximized window. The only way to get rid of them is to use graphical Emacs and enable pixelwise resizing, which you can do by adding following to your init file:

(setq frame-resize-pixelwise t)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy