So this is happening from past few days. When I start Emacs it is displaying rectangular block for each character. enter image description here

and when I start Emacs inside the terminal with the -nw option it starts renders fine inside the terminal. emacs -nw

enter image description here

Not sure of what might be wrong?

  • What Emacs/Spacemacs is that? Please specify just what you are using and how you are using it. Do you see the same problem when you start Emacs using emacs -Q? If not, bisect your init file to find the culprit.
    – Drew
    Commented Oct 20, 2018 at 18:30
  • Thanks for the small review/suggestion. I am using Emacs 25 with the latest spacemacs configuration. I apparently solved the issue. Adding an answer for that.
    – rajudev
    Commented Oct 20, 2018 at 20:30

1 Answer 1


What went wrong ?

A recent script for installing fonts in the i3wm-themer uninstalled the fonts which were being used by my current Emacs configuration. So Emacs was not being able to find those fonts and was displaying the rectangular blocks.

The font configuration was specified in my .spacemacs config file

  dotspacemacs-default-font '("Source Code Pro"
                           :size 13
                           :weight normal
                           :width normal
                           :powerline-scale 1.1)

How I fixed it?

I changed the fonts to an available font such as Monospace and restarted Emacs.

   dotspacemacs-default-font '("Monospace"
                               :size 13
                               :weight normal
                               :width normal
                               :powerline-scale 1.1)

This solved the issue. While solving this I also learned about the M-x menu-set-font which helped me set my fonts using a font selection GUI menu.


  1. Github Issue with similar problems
  2. Set Fonts tutorial on Emacs Wiki

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.