4

I recently installed Magit and began running it. It appears to load just find and all keybindings seem to work perfectly. However, when I intend to commit changes, magit doesn't seem to open my emacsclient and create a new buffer inside of emacs.

Initially, it opened a separate instance of emacs. I then tried changing the default git editor with:

git config --global core.editor emacsclient

Now when I try to commit with

C-x g c c

as I've done before, it no longer opens anything. I checked the process of magit-commit-mode from within emacs and I saw the following:

run git ... commit --
hint: Waiting for your editor to close the file...
libgpm: zero screen dimension, assuming 80x25

Running it again just now left me with something similar

run git ... commit --
-- More --^[[53;11H SPACE/d/j: screen/page/line down, b/u/k: up, q: quit

My current machine where this is happening is running Manjaro on emacs26 if that helps. I even tried reverting my git config back to its original settings (resetting the config as well) and nothing changed. If there is something else I did that would have caused this change in magit's behavior it's not coming to mind.

I then tried my exact same configuration (same .emacs and same emacs version) on my Chromebook running GalliumOS (a Xubuntu based distro), and magit commits work perfectly fine. I can write commit messages from within a new buffer in emacs, close it, and continue with my work.

Is there anyone with any idea of what the issue may be with my particular setup on my main Manjaro machine? Or a pointer in the right direction?

Thanks in advance.

5

This is a known 0-day regression. The fix is across two packages with-editor and magit. Once the new with-editor is available a new magit version that depends on that will be pushed. Then it will take a few hours for that to become available. It appears that will take 10 hours.

For more information, including a workaround, see https://github.com/magit/magit/issues/3632.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.