2

I use spacemacs and while in Python mode, flycheck can not use flake8 checker even when I try to manually enable it using flycheck-disable-checker. I get the following output from flycheck-verify-checker flake8 (colors annotated):

Syntax checker in buffer code_v1.py in python-mode:

  python-flake8 (disabled)
    - major mode:         (green) `python-mode' supported
    - may enable:         (green) yes
    - executable:         (green) Found at /home/user/.virtualenvs/xxx/bin/flake8
    - configuration file: (green) Found at "/home/user/.config/flake8"

(red) Flycheck cannot use this syntax checker for this buffer.

Flycheck Mode is enabled. Use SPC u C-c ! x to enable disabled checkers.

--------------------

Flycheck version: 32snapshot (package: 20181018.1021)
Emacs version:    25.2.2
System:           x86_64-pc-linux-gnu
Window system:    x

Further output:

(xxx) user@host:~$ which flake8
/home/user/.virtualenvs/xxx/bin/flake8
(xxx) user@host:~$ flake8 --version
3.6.0 (mccabe: 0.6.1, pycodestyle: 2.4.0, pyflakes: 2.0.0) CPython 3.6.7rc1 on Linux

Why can't I enable the flake8 checker? What causes Flycheck cannot use this syntax checker for this buffer.?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.