0

How can I as an emacs prelude (-nw) user turn off the 80 column warning highlight seen here:

enter image description here

1

That effect comes from whitespace-mode, enabled by default in Prelude.

If you want to keep the effect but set it at a different column, you can set whitespace-line-column to a value you like. If you want to disable the effect, remove lines-tail from whitespace-style.

Make these changes in your ~/.emacs or init.el (which ever one you use). Something like the following would keep Prelude's default whitespace-mode settings but disable "greater than 80 column highlighting":

;; Change Prelude's default whitespace-mode settings
(setq whitespace-style '(face tabs empty trailing))

And the following should disable all whitespace-mode styling:

;; Turn off whitespace-mode styling
(setq whitespace-style nil)

If you don't care about whitespace-mode at all, you could unload it:

;; Disable whitespace-mode entirely
(unload-feature whitespace-mode)

Although, if another library relies on whitespace-mode, it may not be able to be unloaded.

  • please expand on what you meant by "remove lines-tail from whitespace-style" – american-ninja-warrior Nov 7 '18 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.