1

Emacs version 26.1, compiled on CentOS 7.5 , running ada-mode 5.3.1.

The parser works correctly, but the problem is that keywords aren't being coloured. When I run describe font on the keyword, it is not reporting the word as a keyword. Any one know where to look to correct this? It's a new thing in my new installation; worked fine on 25.1 compiled on RedHat 7.2

Note I get correct behaviour when editting Python, but not Ada.

  • Is ada-mode enabled? Is font-lock-mode enabled? Check with C-h m – nega Nov 9 '18 at 15:46
  • Yes, confirmed. – David Boshton Nov 9 '18 at 15:55
  • Emacs 26.1 with emacs -Q and a small sample Ada file "worksforme". begin/end/loop/return are fontlocked and marked as font-lock-keyword-face. Sorry. – nega Nov 9 '18 at 16:16
  • That's good news. I'll try and rebuild and see if there's anything else I need. – David Boshton Nov 9 '18 at 16:50
  • This was a bug with 5.3.1 and emacs 26.1. It's now fixed in 5.3.2 -- well done Stephen! – David Boshton Nov 19 '18 at 9:56
1

This is now fixed in 5.3.2 of ada-mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.