When I am modifying the internal-border-width of the selected frame the "resizing" happens but for example the minibuffer and the modeline are not visible anymore. They are there but offscreen:unbalanced emacs borders

As you can see the borders are unbalanced and the buffer is "pushed" from the top left.

This is likely to be window manager related (bspwm in my case). Because when I for example full screen emacs after setting the internal border width everything looks as expected. Same when I open another application or anything like that which "repositions" and that causes a "redraw":

after repositioning

Can this be solved from within my .emacs.d or do I need to look in my window manager or somewhere else?

  • Please provide a step-by-step recipe from emacs -Q, stating your Emacs build (M-x emacs-version).
    – Drew
    Nov 9, 2018 at 19:46

1 Answer 1


Found the solution: If you modify certain aspects of Emacs geometry (in my case internal-border-width and it does not seem to be respected by the window system, try putting your settings also in .Xdefaults or .Xresources (I think the latter is preferred nowadays).

See this link for more on this http://www.linux-france.org/article/appli/emacs/manuel/html/resources-x.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.