0

I use ggtags in order to improve my efficiency. I follow the manual to setup emacs environment. https://tuhdo.github.io/c-ide.html

However, during editing the cpp files in the projects. Chance are high that the emacs will not respond. And the background will do something like "Parsing numeric_op.hpp (LL)...done". This will spend more than half an hour to do this. I don't know how to deal with this thing. Does anyone have the same situation? Thank you very much.

  • 1
    Does disabling semantic with M-x semantic-mode help? How long are the lines in the slow files (roughly how many characters in the longer lines)? How many lines do the slow files have? You might want to look at recent threads like these if you want to find out about what modern tools C++ programmers like to use in emacs: reddit.com/r/emacs/comments/7vfbmw/… reddit.com/r/emacs/comments/5yxxrl/… – Croad Langshan Nov 11 '18 at 13:39
  • @CroadLangshan It works. It only 100 lines. It didn't happen but the cost is I disable semantic mode – yuxuan Nov 14 '18 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.