1

I want to install the package running:

M-x package-install RET markdown-mode RET

And I get the following error

package-install-from-archive: https://melpa.org/packages/markdown-mode-20180904.1601.el: Not found

Which is true, since doing via Firefox I get 404 error.

I have the following version of Emacs:

GNU Emacs 26.1 (build 1, x86_64-pc-linux-gnu, GTK + Version 3.22.30)
  of 2018-07-05

How can I install it?

  • try package-refresh-contents then package-install as I see version: 20181112.1529 in my refreshed buffer... – manandearth Nov 21 '18 at 22:46
  • Thank you. I followed your instructions and it worked correctly. I was able to install the package I needed. – Carlos Dagorret Nov 22 '18 at 0:01
1

It's trying to download an older version of the package. Emacs keeps a cache the list of available package versions on every command, to save time and bandwidth. It refreshes the list when you open the package list with M-x list-packages or when you press r (package-menu-refresh) on the list. If you use M-x package-install directly, you may need to refresh the list manually with M-x package-refresh-contents before calling package-install.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.