I use the Evil mode inside Emacs for doing a lot of my work. If I need to run a shell-command and see its output all I need to do is type in normal mode :!<bash command>. The window splits into two halves and displays the output in another buffer named Shell Command Output

However, I notice that when the output is very long (say when one compiles a program) the output buffer shows the top part of the output rather than the bottom part which is where the compilation errors are usually mentioned, and are of immediate interest during programming.

How do I get Emacs to display the ending of the bash command output on running the bash command?

  • How about using the built in compile mechanism?: (setq compilation-scroll-output t) -- M-x compile and then whatever command-line suits your needs. – lawlist Nov 25 '18 at 21:30
  • Perfect! If you post your comment as an answer I will accept it. Thank you! – smilingbuddha Nov 25 '18 at 21:53

One option would be to use the built-in compile mechanism: set the variable compilation-scroll-output to a non-nil value with (setq compilation-scroll-output t); type M-x compile; and use whatever command-line is needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.