2

Q: how can I get get full bidi support for Arabic when installing Emacs from source?

I compiled Emacs from source (v. 26.1) and found that the bidi is not working correctly for Arabic.

The good: I can input Arabic characters in right-to-left form (correct).

The bad: none of the letters connect (Arabic is a scripted language, and the letters are supposed to connect). So, for example, the following phrase:

بسم الله الرحمن الرحيم

gets rendered in Emacs (via emacs -Q) as:

Emacs Arabic display

I was previously using Emacs v. 25, installed via my distro's package manager. I am using the same font as before, which has good support for Arabic characters.

How can I get full bidi support when installing via source?

  • You could look at build scripts used to build the package, you're probably missing a switch in your configure invocation. – DoMiNeLa10 Nov 27 '18 at 16:33
1

You need to make sure that your Emacs is built with support for text shaping. AFAIK, it's the --with-m17n-flt option to configure. This option is activated automatically but only if the relevant include files are found.

On Debian-derived systems a good way to make sure you have all the relevant packages installed is to use something like:

apt-get build-dep emacs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.