0

windows 10, emacs 26.1,

I use package magit to work with git. Nice.

enter image description here

When I press C-<tab> is collapse/expand recent commits: enter image description here

Nice. But if I press <tab> magit do same thing as when I press C-<tab>. So press <tab> and C-<tab> do same things.

How I can disable C-<tab>. I want to bind C-<tab> to another command (no magit command).

4

C-<tab> is bound to magit-section-cycle whereas <tab> is bound to magit-section-toggle. So they are not the same but just happen to do the same in certain (but not all) situations.

If you still want to disable this then the following seems to work

(with-eval-after-load 'magit-status
  (define-key magit-status-mode-map (kbd "C-<tab>") nil))

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.