0

The only response I got is this: Weird behavior: GUI won't start, but terminal emacs will

But he doesn't clarify on the solution. I have the same problem, my .Xdefaults and/or .Xresources causes the error

This is my .Xresources

*.color0: #1d2021
*.color1: #cc241d
*.color2: #98971a
*.color3: #d79921
*.color4: #458588
*.color5: #b16286
*.color6: #689d6a
*.color7: #a89984
*.color8: #928374
*.color9: #fb4934
*.color10: #b8bb26
*.color11: #fabd2f
*.color12: #83a598
*.color13: #d3869b
*.color14: #8ec07c
*.color15: #ebdbb2
!! Transparency (0-255):
*.alpha: 230

If I remove .Xresources emacs starts with no issue at all, but that meeses up with my i3blocks and i3 config

  • 1
    Did you follow the advice about using --debug-init? – tarsius Dec 4 '18 at 19:47
3

Apparently Emacs expects the value of alpha to be within [0, 100], as I can reproduce this issue with alpha set to a value outside of that exact range.

Poking around in its codebase, you can find the x_set_alpha function in src/frame.c signaling an "Args out of range" error on the same condition.

As an immediate fix you can specify an Emacs-specific alpha resource setting to be within that range

Emacs.alpha: 90

or alternatively add (setq inhibit-x-resources t) to your init file to prevent Emacs from loading X resources.

Moreover I'm not sure if this would be regarded as an actual bug upstream. Any application taking an X resource as input is free in the interpretation of its value. Adding custom settings per nonconforming application should be sufficient.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.