0

I am trying to get emacs org-mode to export to pdf. To this end I've installed tex-live and added the path to the bin folder to my emacs path. I've added the tex-live folder to my OS $PATH. When I try to export to pdf I get the following ouput:

(2)/research_plan/research_plan.tex
Processing LaTeX file research_plan.tex...
org-compile-file: File "c:/Users/Terry/tmar080@aucklanduni.ac.nz/Phd_git (2)/research_plan/research_plan.pdf" wasn’t produced.  See "*Org PDF LaTeX Output*" for details

Where do I see Org PDF LAtex Ouput?
Ps I've also tried the following to no avail: Shown below is my init.el file:

;;(require 'package)
;;(package-initialize)
;;(add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/") t)
(require 'cask "~/.emacs.d/.cask/cask.el")
(cask-initialize) 

;; BACKING UP
(setq make-backup-files nil) ;;no ~files
(setq inhibit-startup-message t) ;; start in scratch
(setq auto-save_default nil) ;; no more #files 

;;UI SPECIFIC FEATURES
(desktop-save-mode 1) ;; save workspace between sessions 
(tool-bar-mode -1) ;; no toolbars on top
(scroll-bar-mode -1) ;; no scrollbars
(global-visual-line-mode t);;line wrapping by word
(show-paren-mode t) ;; show matching bracket
(delete-selection-mode t) ;; overwrite selected text on type
(blink-cursor-mode -1) ;;cursor not blinking
(fset 'yes-or-no-p 'y-or-n-p) ;; yes or no is now y or n
(setq-default tab-width 2)
(setq-default indent-tabs-mode nil) ;; autoindent tabs

;;flx ido-mode
(require 'flx-ido)
(ido-mode 1)
(ido-everywhere 1)
(flx-ido-mode 1)
;; disable ido faces tqo see flx highlights.
(setq ido-enable-flex-matching t)
(setq ido-use-faces nil)

;;Save cursor position in file
(require 'saveplace)
(setq save-place-file (concat user-emacs-directory "saveplace.el"))
(setq-default save-place t)

;;projectile
(projectile-global-mode t) 

;;autocomplete
(require 'auto-complete-config)
(ac-config-default) 

;;font and theme
(set-frame-font "Source Code Pro for Powerline-14")
(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(custom-enabled-themes (quote (sanityinc-tomorrow-eighties)))
 '(custom-safe-themes
   (quote
    ("628278136f88aa1a151bb2d6c8a86bf2b7631fbea5f0f76cba2a0079cd910f7d" default)))
 '(flx-ido-threshold 10000)
 '(package-selected-packages
   (quote
    (auto-complete flx-ido color-theme-sanityinc-tomorrow))))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )

;; cygwin bash from within emacs
;; Let's use CYGWIN bash...
;;
(setq binary-process-input t) 
(setq w32-quote-process-args ?\") 
(setq shell-file-name "c:/cygwin64/bin/bash") ;; or sh if you rename your bash executable to sh. 
(setenv "SHELL" shell-file-name) 
(setq explicit-shell-file-name shell-file-name) 
(setenv "PATH"
    (concat "~/bin:/usr/local/bin:/usr/bin:/cygdrive/c/texlive/2018/bin/win32:"
        (replace-regexp-in-string " " "\\\\ "
            (replace-regexp-in-string "\\\\" "/"
                (replace-regexp-in-string "\\([A-Za-z]\\):" "/\\1"
                                          (getenv "PATH"))))))

(require 'shell-here)
(define-key (current-global-map) "\C-c!" 'shell-here)

;;(require 'package)
;;(package-initialize)
;;(add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/") t)
(require 'cask "~/.emacs.d/.cask/cask.el")
(cask-initialize) 

;; BACKING UP
(setq make-backup-file nil) ;;no ~files
(setq inhibit-startup-message t) ;; start in scratch
(setq auto-save_default nil) ;; no more #files 

;;UI SPECIFIC FEATURES
(tool-bar-mode -1) ;; no toolbars on top
(scroll-bar-mode -1) ;; no scrollbars
(global-visual-line-mode t);;line wrapping by word
(show-paren-mode t) ;; show matching bracket
(delete-selection-mode t) ;; overwrite selected text on type
(blink-cursor-mode -1) ;;cursor not blinking
(fset 'yes-or-no-p 'y-or-n-p) ;; yes or no is now y or n
(setq-default tab-width 2)
(setq-default indent-tabs-mode nil) ;; autoindent tabs

;;flx ido-mode
(require 'flx-ido)
(ido-mode 1)
(ido-everywhere 1)
(flx-ido-mode 1)
;; disable ido faces tqo see flx highlights.
(setq ido-enable-flex-matching t)
(setq ido-use-faces nil)

;;Save cursor position in file
(require 'saveplace)
(setq save-place-file (concat user-emacs-directory "saveplace.el"))
(setq-default save-place t)

;;projectile
(projectile-global-mode t) 

;;autocomplete
(require 'auto-complete-config)
(ac-config-default) 

;;font and theme
(set-frame-font "Source Code Pro for Powerline-14")

(setq Tex-PDF-mode t) 
1

Try the following: Export to LaTeX only and run the resulting LaTeX-file manually through pdflatex by running pdflatex <filename>.tex Then check the file <filename>.log for any errors. You are on Windows, so you installed TeX from the official distribution (which is good, TeX Live on Unix/Linux gets sometimes mixed up with Linux-distribution-specific TeX distributions).

  • Running pdflatex revealed that a lot of packages were missing from my cygwin texlive distro so I installed the texlive windows version and added it to my emacs path and ran pdflatex from the windows texlive bin folder and it worked. Thank you so much!!! – Teererai Marange Dec 10 '18 at 22:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.