0

I am trying to use flyspell and I get the following Error.

Starting new Ispell process aspell with C:/Users/cuspi/AppData/Roaming/Aspell/dict/en dictionary... ispell-init-process: Unhandled Error: c:/Users/cuspi/AppData/Roaming/Aspell/dict/en-only.rws: The key "affix" is unknown.

My init.el for Flyspell looks like:

;; -------------------- FLYSPELL --------------------

(add-to-list 'exec-path 
"C:/Users/cuspi/AppData/Roaming/Aspell/bin/");path to executable

(setenv "DICTIONARY" "en")

(eval-after-load "flyspell"
  '(progn
 (define-key flyspell-mouse-map [down-mouse-3] #'flyspell-correct-word)
 (define-key flyspell-mouse-map [mouse-3] #'undefined)))

(setq ispell-program-name "aspell") ; Engine for spellcheck. Could be ispell

(setq ispell-dictionary "en") ; The language you want to support.

(setq ispell-personal-dictionary (locate-user-emacs-file "C:/Users/cuspi/AppData/Roaming/Aspell/dict/en"))

(setq ispell-dictionary "C:/Users/cuspi/AppData/Roaming/Aspell/dict/en") 


 ; Will use ispell-local-dictionary-list
(setq ispell-extra-args
  '("--run-together" "--run-together-limit=5" "--run-together-min=2"))

(add-hook 'emacs-lisp-mode-hook 'flyspell-prog-mode)

(require 'flyspell)

;---------------------------------------

Could someone please help? I have tried several things, reinstalling aspell, dictionaries and other things I've seen online but nothing works.

Thanks!

migrated from tex.stackexchange.com Dec 12 '18 at 16:58

This question came from our site for users of TeX, LaTeX, ConTeXt, and related typesetting systems.

  • Have you tried running the basic aspell from the command line to see what it does then? Also, have you tried it without adding any of the settings after ispell-program-name so that you can see if one of them is triggering the problem? – Win Dec 15 '18 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy