3

I've installed OpenSSH on a Windows 10 machine, and can connect to it from the Linux command line with ssh or scp, giving the cmd.exe "shell". But tramp hangs on Waiting for prompts from remote shell:

Tramp: Opening connection for win using ssh...
Tramp: Sending command ‘exec ssh   -o ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e none win’
Tramp: Waiting for prompts from remote shell...failed
Tramp: Opening connection for win using ssh...failed

also with (setq tramp-use-ssh-controlmaster-options nil)

Tramp: Opening connection for win using ssh...
Tramp: Sending command ‘exec ssh    -e none win’
Tramp: Waiting for prompts from remote shell...failed
Tramp: Opening connection for win using ssh...failed

Is there some special trick?


I've tried changing the Windows OpenSSH shell to bash, which makes regular ssh-ing and git cloning nicer, but doesn't seem to help tramp.

I've also tried both

 (setq explicit-shell-file-name "cmd"
       explicit-cmd-args '("/q"))

and

 (setq explicit-shell-file-name "powershell"
       explicit-powershell-args '("-file" "-"))

to no avail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.