1

I have a gpg file I occasionally need to access from ubuntu 18.04 gnome desktop or xfce desktops in linux, or via a terminal in an ssh session. On the gnome desktop, everything works reasonably easily, a new desktop window pops up for password entry, however on xfce there is typically at 10+ second wait for the window to appear, and when in a terminal, I never get prompted for password entry and the gpg request just times out.

Is there any way to access gpg more quickly? Perhaps entirely from within gpg and the shell (I suspect the problem somehow is with the gui aspect of the desktop).

I am using GNU Emacs 25.2.2 (x86_64-pc-linux-gnu, GTK+ Version 3.22.21) of 2017-09-22, modified by Debian.

EDIT: delay is 25 sec

  • This could be something to do with gpg-agent or /bin/pinentry-gnome3 or /bin/pinentry - you might try googling around those terms. pinentry-gnome3 is used in the GUI, plain pinentry on the command-line. Perhaps make sure they are installed? – wef Dec 25 '18 at 22:49
  • Very useful search terms. Led me to this and some like of which, all of which I tried without success. It does seem the timeout is closer to 25 sec rather than 10+ as I mentioned above, thus it does seem to be some official timeout period that is built in, as referenced here – Karl Berggren Dec 30 '18 at 17:44
  • Have you tried running strace? – Croad Langshan Jan 4 '19 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.