0

I've recently added some custom entries to my org-entities-user (below), but they do not display as UTF-8 characters, even with org-toggle-pretty-entities on. Is it because they are more than one UTF-8 character long? Any ideas how to change this behaviour?

(setq org-entities-user
      '(("dO" "\\(\\delta^{18}\\)O" nil "&delta;<sup>18</sup>O" "δ18O" "δ18O" "δ¹⁸O")
        ("eO" "\\({}^{18}\\)O" nil "<sup>18</sup>O" "18O" "18O" "¹⁸O")
        ("dC" "\\(\\delta^{13}\\)C" nil "&delta;<sup>13</sup>O" "δ13C" "δ¹³C" "δ¹³C")
        ("tC" "\\({}^{13}\\)C" nil "<sup>13</sup>C" "13C" "¹³C" "¹³O")
        ("COt" "CO\\(_{2}\\)" nil "CO<sub>2</sub>" "CO2" "CO₂" "CO₂")
        ("D" "\\Delta_{47}" t "&Delta;<sub>47</sub>" "Δ47" "Δ47" "Δ₄₇")
        ("celsius" "\\(^{\\circ}\\)C" nil "&deg;C" "°C" "°C" "°C")
        ;; unit space, something like 15\us{}Ma
        ("us" "\\," nil "&nbsp;" " " " " " ")
        ("appr" "\\sim" t "&tilde;" "~" "~" "~")
        ;; for gps-coordinates
        ("degree" "^{\\circ}" t "&deg;" "°" "°" "°")
        ("arcminute" "^{'}" t "&prime;" "'" "′" "′")
        ("arcsecond" "^{''}" t "&Prime;" "\"" "″" "″")
        ))
1

Apparently, currently custom entities of more than one UTF-8 character are not previewed. I've submitted a feature request to the mailing list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.