3

I did something causing the -R (--reset-author) switch in the Commit menu to always be on by default. How can I reset this?

  • 1
    Is it still on if you restart your Emacs? You could toggle it by type - R in case you don't know that yet. – whatacold Dec 23 '18 at 2:48
  • I had tried - R. It did toggle, but switch would be back on again the next time I committed. I now tried restarting Emacs. That fixed the problem. Thanks!| (any idea why this happened? I'm not used to that kind of weird statefulness in Emacs; it's been a long time since I last had to restart). – David Goldfarb Dec 23 '18 at 11:09
  • I think that's because you somehow set magit-commit-arguments, and I've posted it as an answer, please have a check if it helps :) – whatacold Dec 23 '18 at 11:36
5

As with other Magit popups, set the flags the way you want them to be by default, and type C-cC-c.

(n.b. This is likely how you got into that situation in the first place.)

See C-hf magit-popup-set-default-arguments

(or type ?C-cC-c in the popup buffer.)

1

I can reproduce your problem by setting (default is nil ):

(setq magit-commit-arguments '("--reset-author"))

So check this variable in your config, and remove "--reset-author" from it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.