0

evil mode j and k in markdown and text modes moves down paragraphs (and sometimes to other arbitrary points down/up the paragraph) instead of up and down a single line. How can I change this behaviour?

migrated from superuser.com Jan 4 at 16:56

This question came from our site for computer enthusiasts and power users.

  • What does F1 k j say? I have a hard time believing this is Evil's fault. – wasamasa Jan 4 at 18:50
  • Here's what it says: j runs the command evil-next-line (found in evil-motion-state-map), which is an interactive compiled Lisp function in evil-commands.el'. It is bound to <down>, j. (evil-next-line &optional COUNT) Move the cursor COUNT lines down.` – spheroid Jan 4 at 18:52
0

This is likely happening because you have visual-line mode enabled and each paragraph is a single line. You can rebind j and k to move by visual line (evil-next-visual-line for j, for instance).

  • This worked thanks! – spheroid Jan 5 at 14:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.