1

I am running the mac port version of emacs that I installed via homebrew (see here). I'm also trying to run the Emacs server to avoid long startup times.

To do this, I first run the server:

/Applications/Emacs.app/Contents/MacOS/Emacs --daemon

This process appears to complete successfully. The next step is to start an emacs client like so:

/Applications/Emacs.app/Contents/MacOS/bin/emacsclient -n -c

However, when I run this command, nothing happens at all. If I run the command, without the -c option, a client opens in the terminal, but I want to run Eamcs in Cocoa.

Has anyone run into this problem?

1

I've been trying to figure out how to get a single emacs server running and having the ability to spin up emacsclients in GUI and TTY. Apparently, this is not possible in the Mac port due to (in the developer's words):

The developer has no idea how to detach Emacs as a GUI application from Window Server or Dock without separating a GUI process (not thread) from the main Emacs (Lisp evaluator) process.

See https://github.com/railwaycat/homebrew-emacsmacport/issues/52 for more info

| improve this answer | |
  • btw, for anyone interested, I finally got everything to work with emacs-plus. After install, I can start the server with brew services start emacs-plus and launch emacsclient in GUI and TTY. Woop woop! – aiguofer Jan 7 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.